ePrism experiencing delayed delivery
Incident Report for Network Center, Inc.
Resolved
Issue appears to be resolved. Operations have returned to normal.
Posted Aug 24, 2016 - 07:03 CDT
Investigating
There is a high volume malware attack underway that is resulting in email delays for some customers. ePrism engineers are investigating and working to mitigate this issue.
Posted Aug 23, 2016 - 19:41 CDT