Unable to reach support via phone
Incident Report for Network Center, Inc.
Resolved
Issue has been identified and resolved.
Posted Nov 02, 2016 - 11:01 CDT
Investigating
The inbound calling appears to be down. We're currently investigating and hope to have the issue identified shortly.
Posted Nov 02, 2016 - 10:17 CDT