Call center unable to receive inbound calls
Incident Report for Network Center, Inc.
Resolved
Inbound call processing issue was resolved approximately 6:00pm CST
Posted Jun 22, 2016 - 20:00 CDT
Investigating
The call center is currently unable tof receive inbound calls. All other services are currently available.
Posted Jun 22, 2016 - 14:55 CDT