ePrism delayed deliver
Incident Report for Network Center, Inc.
Resolved
Issue has been resolved as of 7PM CST on 4/12/2016
Posted Apr 12, 2016 - 11:52 CDT
Investigating
We've identified an issue with delayed email delivery and are currently investigating.
Posted Apr 12, 2016 - 11:27 CDT