Inbound Calling - Call Center
Incident Report for Network Center, Inc.
Resolved
This incident has been resolved.
Posted Oct 28, 2016 - 15:48 CDT
Investigating
We've identified an issue with calls reaching our phone queue. We're investigating the cause and hope to have it resolved shortly.
Posted Oct 28, 2016 - 15:40 CDT