ZixCorp Degraded.
Incident Report for Network Center, Inc.
Resolved
ZixCorp has resolved a temporary issue with ZixCorp's hosted mail systems. During this time your secure email users may have had intermittent issues while attempting to send encrypted emails or emails may have been delayed.
Posted Apr 25, 2016 - 19:54 CDT
Investigating
ZixCorp is currently experiencing a temporary issue with ZixCorp's hosted mail systems. During this time your secure email users may have intermittent issues while attempting to send encrypted emails or email may be delayed.
Our engineers are currently working on the problem and we expect to have a resolution shortly. We apologize for any inconvenience this may cause and we will provide an update shortly.

This information is also available on our status page https://status.zixcorp.com/
Posted Apr 25, 2016 - 08:57 CDT