Call Center Outage
Incident Report for Network Center, Inc.
Resolved
The issues with telco have been resolved and phone service restored.
Posted Jun 01, 2017 - 10:59 CDT
Identified
We've identified the issue lies with our telco. There may be a widespread outage in the area. They're investigating and will be updating us as they have more info.
Posted Jun 01, 2017 - 08:25 CDT
Investigating
We've identified an issue with inbound calls not being able to reach our support center. We're currently investigating to determine the cause and hope to have an update shortly.
Posted Jun 01, 2017 - 07:51 CDT