Ticketing Issue
Incident Report for Network Center, Inc.
Resolved
The ticketing issue has been resolved.
Posted Aug 03, 2016 - 17:38 CDT
Investigating
We've identified an issue where inbound emails aren't creating tickets.
Posted Aug 03, 2016 - 17:13 CDT